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Tutorial: Oculus Quest 2 mit Unity3D verbinden
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In diesem Virtual Reality Tutorial zeige ich Ihnen, wie das Oculus Quest 2 mit Unity3D verbinden
kénnen

Dieser Artikel erfordert mehr Erfahrung im Umgang mit Unity3D und ist daher nur fur
fortgeschrittene Benutzer gedacht.
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Dieses Tutorial ist als praktischer Leitfaden gedacht und behandelt keine theoretischen
Hintergrinde. Diese werden in einer Vielzahl von anderen Dokumenten im Internet behandelt.

Fur die Richtigkeit der Inhalte dieses Tutorials gebe ich keinerlei Garantie. Der hier gezeigte Weg
ist nicht der einzige um ein solches System aufzusetzen, es ist lediglich, der, den ich bevorzuge.

Um ein das Oculus Quest 2 nutzen zu kénnen, ist ein Facebook-Account zwingend notwendig. In
Deutschland ist das Oculus Quest 2 derzeit nicht bestellbar.

Was ist Unity3D?

Unity3D ist eine Laufzeit- und Entwicklungsumgebung fir interaktive 3D-Grafik-Anwendungen des
Unternehmens Unity Technologies. Zielplattformen sind neben PCs auch Spielkonsolen, mobile
Gerate und Webbrowser. Die Entwicklungsumgebung gibt es fir Windows, Linux und macOS. In
diesem r23 : Blog Tutorial verwende ich ein Windows System.

https://unity.com/de

Unity3D fir Oculus Quest 2 vorbereiten

Unity Hub auf dem System starten und ein neues 3D Projekt anlegen.
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@ Unity Hub 2.4.2

@ unity

@ Projects P[’ojects ADD

“

Learn

= Community

Installs

lii

\_

You have no project here.

Click on New if you want to create one, Add if you want to add one to
your project list. Visit the Learn section if you prefer a tutorial to get
started.
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You have no project here.

Click on New if you want to create one, Add if you want to add one to
your project list. Visit the Learn section if you prefer a tutorial to get
started.
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2 Unity Hub 2.4.2 = O x

@ uni @ Create a new project with Unity 2020.1.17f1 = O X

3D

M

This is an empty 3D project that uses Unity's built-in renderer.

[+ I

Fir das Virtual Reality-Headset richten wir ein neues 3D Projekt ein.
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4 Create a new project with Unity 2020.1.17f1

Templates

3D

= O *
Settings
Project Mame *
First_v2
Diwr_weltyw2
CAMNCEL 5 | CREATE

Nach dem Einrichten es neues 3D Projektes startet Unity3D
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B First 2 - SampleScene - PC, Mac & Linux Standalone - Unity 2020.1.17f1 Personal <DX11> .
File Edit Assets GameObject Component | Window Help

Panels

Next Window Cirl+Tab

Previous Window Ctrl+ Shift+ Tab

Layouts

Collaborate
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TextMeshPro
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Rendering

Animation

Audic

Sequencing

Analysis

Ul Toolkit

Unter Windows hier Asset Store gehen wir zur Unity3D Website.
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B First_v2 - SampleScene - PC, Mac & Linux Standalone - Unity 2020.1.17f1 Personal <DX11>

File Edit Assets GameObject Component Window Help

© Inspector

<@ unity Asset Store

The Asset Store has moved

You can visi tore v site from 2020.1 onwards, and also import

your pur 3 Package Manager.

Search online

Importing your assets from the Package Manager

To download or view your purchased assets, go to Window > Package

Manager and select My Assets or click the Open Package Manager button
below.

* Favorites

G Assets
[ ]

I Packages

8/36


https://blog.r23.de/wp-content/uploads/2020/12/unity_vr_brille_06.jpg

Virtual Reality, Augmented Reality und 3D-News : R23 - Hagen NRW
Mit offenen Augen trdumen
https://blog.r23.de

Oculus Integration |

< C @

B) Amazonde cm cBay @ Facebook > YouTube

Q unityAssetStore  Assetsv  Tools¥  Servicesv By Unityv  Industries v

Q

© Over 11,000 5 star assets @ Rated by 85,000+ customers @ supported by over 100,000 forum members

Home > Tools > Integration > Oculus Integration

1] Oculus Integration

© Oculus *kkirvr 3 | 441 Reviews
FREE
I

T ECEDE
o artuarlouis

*k kK 7daysago

What an incomplete thing!

What an incomplete thing! but its mandatory. Unless
you dont install XR Plugin Management, then activate
Oculus plugin, and then Switch Platform... a...

D License Extension Asse
File size 3742 MB
@0 Latest version 230
Latest release date Dec 4, 2020
Supported Unity versions 2018.4.3 or higher
Support Visit site
Description Package Content Releases

In dem Online-Shop suchen wir die kostenlose Erweiterung Oculus Integration.

Oculus-Integration fur Unity - 20.1

Unity bietet integrierte VR-Unterstitzung fur Oculus-Gerate. Das Oculus-Integrationspaket fugt
Skripte, Prefabs, Beispiele und andere Ressourcen hinzu, um die eingebaute Unterstitzung von
Unity zu erganzen.

Das Paket enthélt eine Schnittstelle zur Steuerung der VR-Kamera, eine First-Person-Control, eine
einheitliche Eingabe-API fur Controller, Rendering-Funktionen, Debugging-Tools und mehr.

9/36


https://blog.r23.de/wp-content/uploads/2020/12/unity_vr_brille_07.jpg

Virtual Reality, Augmented Reality und 3D-News : R23 - Hagen NRW
Mit offenen Augen traumen

https://blog.r23.de

Wir wahlen Oculus-Integration aus.

Integration

Version 23.0.0 - December 04, 2020 [ass

In Unity3D priifen wir noch einmal die Richtigkeit und die Systemanforderungen und klicken auf
Download von Oculus-Integration.
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File Edit Assets GameObject Component Window Help

Oculus Integration

Version 23.0.0 - December 04, 2020

d Unity Versions

or higher

Nach dem Download erfolgt die Installation von Oculus-Integration.
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File Edit s GameObject Component fow Help

e i ® Inspector
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B Oculus Integration

Version 23.0.0 - December 04, 2020

upported Unity Versions
or higher

Import
8
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E Oculus Integration

Oculus Integration

Version 23.0.0 - December 04, 2020

Nach der Installation prifen wir das System auf Updates.
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File Edit Assets GameObject Component Oculus Window Help

B Oculus Integration

Version 23.0.0 - December 04, 2020

Package Size s saad Unity Versions
Update Oculus Utilities Plugin =1 higner

Ocuus Ubites has detected that a newer OVRPhigin
is avaiable, Using the newest version i
Q recommended. Do you want to enable t?

Current version: {Unknown)
Available version: 1.55.0

0 Yes No o, Don't Ask Again

Import

[
M Packages
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File Edit As GameObject  Component Oculus Window Help

© Inspector

B QOculus Integration

Version 23.0.0 - December 04, 2020

Supported Unity Versions

Purchased Dat OVRPlugin has been updated to 1.5.0.

Flesse restart the Unity Editor to complete the update
ocess.

@ Restart Not Now

Import

M Packages

Q@ [PackageManager] Err

15/36


https://blog.r23.de/wp-content/uploads/2020/12/unity_vr_brille_13.jpg

Virtual Reality, Augmented Reality und 3D-News : R23 - Hagen NRW
Mit offenen Augen traumen
https://blog.r23.de

File Edit Assets GameObject Component Oculus Window Help

Name & v Filters Clear Fil

B Oculus Integration

Version 23.0.0 - December 04, 2020

Package Size Supported Unity Versions

t higher

New spatalizer pugin found. Do you want to
upgrade? If you choose 'Upgrade’, the old plugin il
be renamed to AudioPluginOculusSpatialzer.old

Upgrade | | Delete new plugin | | Don'tupgrade

Import

[
M Packages
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Oculus Integration

Version 23.0.0 - December 04, 2020

Supported Unity Versions

Spatiaiizer plugins has been upgraded.

Flesse restart the Unity Editor to complete the update
ocess.

@

Das war schon alles! Ich hoffe, dass dieses Tutorial hilfreich fur Sie ist.
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Assets > Oculus
AudioMan, Avatar Lipsyn Patform  SampleFr Spatialze wR OeulePro)

Oculus auf dem Smartphone starten
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Einstellungen

#%9 Ralf Zschemisch

Oculus Quest 2 rerwel e

In der Nahe 1

€3 Neues Headset koppeln

Oculus-PIN zuriicksetzen
Zweistufige Authentifizierung
Privatsphire-Einstellungen
Benachrichtigungen

CE} Streaming

Zahlung

[@ zahlungsmethoden

[%] Code einlésen 3

0]

Einstellungen
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Eine Verbindung zur Oculus Quest 2 aufbauen. In den Einstellungen den Entwicklermodus
aktivieren. Es ist ein Facebook-Entwickler-Account zwingend notwendig.
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“« Weitere Einstellungen

Sperrmuster

Sprache d@ndern

Auf Werkseinstellungen zuriicksetzen

Entwicklermodus

Energieeinstellungen

Erweiterte Einstellungen

Informationen zu diesem Headset
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In Unity erstellen wir nun die Virtual Reality - App

A First_v2 - SampleScene - PC, Mac & Linux Standalone - Unity 2020.1.171 Personal <DX11> = X
File | Edit Assets GameObject Component Oculus Window Help
New Scene N
Open Scene 0

& Package Manager
Save Ctrl+s.
Save As. CtrlShift+ 5

€ unity Asset Store

New Project.
Open Project.

The Asset Store has moved

Build Settings... cmsn” You e W nd also import
Build And Run e your purcl

Exit

Search online

Importing your assets from the Package Manager

To download or view your purchased assets, go to Window > Package
Manager and select My Assets or click the Open Package Manager button
below.

culus
AudioMan, LipSyn Platform . . R o

B Packages

24136


https://blog.r23.de/wp-content/uploads/2020/12/vr_app_01.jpg

Virtual Reality, Augmented Reality und 3D-News : R23 - Hagen NRW
Mit offenen Augen traumen

https://blog.r23.de

Oculus

AudioMan, Avata Lipsyn. Platform SampleF Spat

)

Player Settings.. Switch Platform
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Player Setiings. 1

@ OVREngineConfigura
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File Edit s GameObject Component Oculus Window Help

© Inspector

Player

Resolution and Presentation
Splash image

Other Settings
Rendering
Gamma

Player Setfings... Build And Run

A File C\Users\ralfz\ android\repositories
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File Edit Assets GameObject Component Oculus Window Help
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XR Plugin Management

XR Plugin Management

Build And Run

Fur die Darstellung von Virtual Reality Inhalten benétigt unsere App noch ein XR Plugin
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XR Plug-in Management

Information about configuration, tracking

Player Setfings... Build And Run
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XR Plug-in Management

Lg-in Pro

Timeliny

Oculus

Player Setfings... Build And Run

Wir legen die Qualitéat fest.
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File Edit Assets GameObject Component Oculus Window Help
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Player Setfings... Build Build And Run
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Oculus

Player Setiings..

Abschlie3end noch unter Time die zu lhrem Virtual Reality-Headset passende Einstellung fir Fixed
Timestep eintragen.
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Jetzt sind Sie gefragt!

Haben Sie Anregungen, Ergdnzungen, einen Fehler gefunden oder ist dieser Beitrag nicht mehr
aktuell? Dann freue ich mich auf lhren Kommentar.

Sie kénnen diesen Beitrag nattrlich auch weiterempfehlen. Ich bin Ihnen fir jede Unterstlitzung
dankbar!
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Verwandeln Sie lhren Commerce mit AR und 3D-Produktvisualisierung!

Bei uns geht es um Techniken, die es schaffen, das Produkt zum Erlebnis zu machen. Virtual &
Augmented Reality, 360 Grad-Videos, Darstellungen in 3D, virtuelle Showrooms. Die
Besucher:innen sollen eintauchen in die Welt des Unternehmens mit immersiven Technologien.

Sie kénnen uns mit der Erstellung von individuellen 3D-Visualisierungen beauftragen. Jeder kann
3D-Visualisierungen bei unserem Kreativservice bestellen - unabhéngig davon, ob Sie nur ein
einzelnes 3D-Modell benétigen oder viele.

Wir unterstitzen Sie bei der Umsetzung lhres Augmented Reality (AR) oder Virtual Reality (VR)
Projektes! Egal ob Produktfotografie, 3D-Scan-Service, 3D-Visualisierung oder fertige 3D-Maodelle
fur AR/VR — wir beraten Sie personlich und unverbindlich.

Wo kann ich Anregungen, Lob oder Kritik aul3ern?

Ihre Meinung ist uns wichtig! Schreiben Sie uns, was lhnen in Bezug auf unser Angebot bewegt.
info@r23.de
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R23 — Ihr Atelier fur Virtual Reality und interaktive Markenerlebnisse

Winschen Sie ein individuelles Angebot auf Basis Ihrer aktuellen Vorlagen, nutzen Sie einfach
unser Anfrageformular.

Tutorial: Oculus Quest 2 mit Unity3D verbinden
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Besuchen Sie uns auch auf Facebook und Twitter.

r23

Thuringenstr. 20

58135 Hagen

Deutschland

Telefon: 02331 /9 23 21 29

E-Mail: info@r23.de

Ust-1dNr.:DE250502477
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